Patches & Updates SOAP Access Security Patch



29 Mar 2006

H-Sphere versions:   2.4.3 and 2.5

All H-Sphere owners are recommended to apply this security patch in addition to security measures as of Mar 28 and Mar 25.

Note: This patch is deprecated with the newer patch!
Those who use H-Sphere XML API, please apply the newer patch instead of this one, to be able to configure SOAP access from particular IPs.

Run this patch to block access to your CP server via SOAP.

  1. Log into your control panel server as root:
    su -
  2. Download the security patch:
    Linux:
    wget http://www.psoft.net/shiv/HS/axis_servlet_hotfix_060329.tgz
    FreeBSD:
    fetch http://www.psoft.net/shiv/HS/axis_servlet_hotfix_060329.tgz
  3. Unpack the archive:
    tar zxf axis_servlet_hotfix_060329.tgz
  4. Run the script:
    ./axis_servlet_hotfix_060329.pl

    Note: Running the script may take a few minutes. Please be patient.

  5. Restart H-Sphere.


Copyright 1998-2008. Positive Software Corporation.
All rights reserved.