Patches & Updates PostgreSQL 7.4.8 Upgrade



23 May 2005

H-Sphere versions: 2.4.1 Patch 2 and higher

We recommend upgrading your PostgreSQL user database servers and the system PostgreSQL to version 7.4.8 for better performance on the Control Panel server.

This script includes PostgreSQL Security Release for 7.4.8 and fixes:
- Character conversion vulnerability
- contrib/tsearch2 module vulnerability to avoid unsafe use of INTERNAL function results

Read more at:
- http://www.postgresql.org/about/news.315
- http://www.us-cert.gov/cas/bulletins/SB05-131.html#postgresql2

System Requirements:

- H-Sphere 2.4.1 Patch 2 and higher. With H-Sphere older than 2.4.1 Patch 2, Postgres update can stop H-Sphere work.
- If your Postgres is older than v.7.2, manual update is highly recommended.

Update Procedure:

  1. Log into your control panel server as root:
    su -
  2. Download the PostgreSQL 7.4.8 upgrade script from the psoft site:
    For Linux:
    wget http://www.psoft.net/shiv/HS/u-pgsql-7.4.8.tar.gz
    For FreeBSD:
    fetch http://www.psoft.net/shiv/HS/u-pgsql-7.4.8.tar.gz
  3. Unpack the archive:
    tar -zxf u-pgsql-7.4.8.tar.gz
  4. Enter the unpacked directory:
    cd u-pgsql-7.4.8
  5. To upgrade all PostgreSQL servers, run the update.sh script:
    sh update.sh

    To run the script and view the messages that appeared during installation, run the following command:

    sh update.sh | tee update.log
    It will copy the messages to the log file.



Copyright 1998-2008. Positive Software Corporation.
All rights reserved.