H-Sphere Documentation Upgrades

 

Upgrading H-Sphere to 2.097

 

Before you start the upgrade, you need to identify which H-Sphere version is currently installed in your system.
Login as root to your server with H-Sphere CP installed. In version 2.08 and higher, you can identify the version by viewing the HS_VERSION file in the command line:

# cat ~cpanel/shiva/psoft_config/HS_VERSION

You should see the line similar to this:
2.08.1219
where
2.08 - your current H-Sphere version
1219 - installation month and day

If you don't have this file, you have an earlier H-Sphere version (2.06 or 2.07). In this case, you can define your current version visually through the following indicators:
2.06 - No "Change Default Language" feature (Info > Language in the Admin CP menu) or any other of the features below
2.07 - "Change Default Language" feature (Info > Language in the Admin CP menu)
2.08 - Language switch on the Main Login page


After you have learned your H-Sphere version, you can start the upgrade.
Below is the description of upgrade to 2.097. When upgrading to higher versions, use the same procedure.

NOTE1 : When upgrading from H-Sphere 2.08 that is currently running on your server, upgrade to 2.08 first.

NOTE2 : You have to upgrade subsequently from one version to the next one, e.g. 2.06 > 2.07 > 2.08 > 2.09 etc., not 2.07 > 2.09.

  1. Change to the /root/inst directory:

    # cd /root/inst

    Only for 2.08 version running (see NOTE 1 above): remove the current 2.08 version

    # rm -rf ./U208.tgz

  2. Download the update archive of the next version (in this case 2.097)

    # wget http://www.psoft.net/shiv/U2097/U2097.tgz

  3. Unpack the archive:

    # tar xfz ./U2097.tgz

  4. Change to the update directory:

    # cd ./U2097

  5. Stop the H-Sphere Control Panel processes

    • If you use Tomcat, run
      # ~cpanel/tomcat/tomcat.sh stop

    • If you use JServ, run
      for Linux
      # /etc/rc.d/init.d/httpdcp stop

      for FreeBSD
      # /usr/local/etc/rc.d/apache.sh stop

    *To find out whether your system runs JServ or Tomcat, run the following command:

    # ps axuw | grep java

    In the lines that appear on the screen, you will see either Tomcat (which means that Tomcat is used) or org.apache.JServ (meaning that JServ is used).

  6. Run the update:

    # make install

  7. After completing the update procedure, start the H-Sphere Control Panel

    • If you use Tomcat, run
      # ~cpanel/tomcat/tomcat.sh start

    • If you use JServ, run
      for Linux
      # /etc/rc.d/init.d/httpdcp start

      for FreeBSD
      # /usr/local/etc/rc.d/apache.sh start

Repeat the procedure if necessary to upgrade to the next version.


NOTE: When updating to 2.097, the system will ask you the logical server name where Postgres hosting should be located. Enter pgphp.domain.com, where domain.com is your domain name.

RELATED: For information on upgrading Windows servers click here.

Please remember that allowing PSoft Support Team to upgrade your system serves it best. USE THE INSTRUCTION ABOVE AT YOUR OWN RISK!!!



Copyright 1998-2006. Positive Software Corporation.
All rights reserved.