Parallels H-Sphere Documentation System Administrator Guide

 

Upgrading Perl Modules

 
 

Related Docs:   Mod_Perl Installation Supported Perl Versions

Last modified: 14 Nov 2005

 

WARNING: This documentation covers Parallels H-Sphere versions up to 3.1. For the latest up-to-date Parallels H-Sphere documentation, please proceed to the official Parallels site.

H-Sphere requires the following Perl modules on all its servers:

DBI
Digest-MD5
HTML-Parser
HTML-Tagset
LWP-ParallelUA (libwww in FreeBSD)
Mime-Base64
Net-DNS
URI
DBD-Pg
DBD-MySQL (MySQL-modules in FreeBSD)
Quota
MD5
Net
Data-ShowTable
GD-1
perl-Crypt-PasswordMD5
Crypt-Passwd

The above modules are assembled into a ready install packages and are available for public download.

We strongly recommend you NOT to upgrade the modules listed above as they proved to provide the most optimal performance. However, if you decide to upgrade modules, please follow this upgrading procedure at your own risk:

  1. Download the file from www.cpan.org
  2. untargzip the archive
  3. cd into directory
  4. Compile and install the package:
    perl Makefile.PL
    make
    make install

During the upgrade, it may turn out that additional packages are required. You need to set up these packages and try the installation again. If you don't know where to get these packages, try cpan.org

Alternatively, you can update perl modules using the perl CPAN.pm module.

WARNING:
DO NOT try to upgrade H-Sphere Perl core in any case, since it will affect H-Sphere system performance. Restoring the system by our technicians is a subject to extra support charges.

Related Docs:   Mod_Perl Installation Supported Perl Versions



© Copyright 2017. Parallels Holdings. All rights reserved.