Parallels H-Sphere Documentation System Administrator Guide

 

Script Runner Update

 
 

Related Docs:   Script Runner

Last modified: 18 Jan 2005

 

WARNING: This documentation covers Parallels H-Sphere versions up to 3.1. For the latest up-to-date Parallels H-Sphere documentation, please proceed to the official Parallels site.

H-Sphere script runner is a utility, which resides on all H-Sphere servers and is used by H-Sphere to call and run its scripts. It is recommended that you have a script runner no older than version 1.8.

To update script runner:

  1. Download script runner 1.8 (or later if available) for your operating system:

    FreeBSD:

    fetch http://www.psoft.net/shiv/HS/FBSD4/hsphere-script-runner-1-8.tgz
    Linux:
    wget http://www.psoft.net/shiv/HS/<OS_CODE>/hsphere-script-runner-1-8.rpm
    for list of OS codes, see Download Locations.
  2. On every Unix/Linux server, log in as root and update script-runner:

    Linux:

    Check for script-runner data in the rpm database:
    # rpm -qa | grep script-runner
    If it's there, run the update:
    # rpm -Uvh hsphere-script-runner-1-8.rpm
    If it's not, run the installation:
    # rpm -ivh hsphere-script-runner-1-8.rpm
    FreeBSD:
    Check for script-runner data in pkg_info:
    # pkg_info | grep script-runner
    If it's there, run the update:
    # pkg_update hsphere-script-runner-1-8.tgz
    If it's not, run the installation:
    # pkg_add hsphere-script-runner-1-8.tgz
  3. Restart H-Sphere

Related Docs:   Script Runner



© Copyright 2017. Parallels Holdings. All rights reserved.